using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\w+)\](.*)\[\/\1\]";
string substitution = @"$2";
string input = @"
[shake2][wave]朝から私の大好きな[scream][big]死[/scream][/big]のにおいがするな...[/wave][/shake2]
[shake2]お前を殺すには骨がおれるが、しかし利益は大きい。ハッハッハ![/shake2]
[shake2]おや、心がおれそうだって?もう全てを放り出してあきらめたらどうだ。キッド[/shake2]
[shake2]そんなに死んでしまうのが好きなら、死とチューしちゃえばいいのに![/shake2]
何か無くなった気がするだって?もし、お前が[icon:camerabadge]カメラバッジを持っているなら、撮影ポーズ中に見回して、その[name]何か[/name]を探してみればいい...";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}