#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?://www\.foo\.com(?:/\S*)*|sc-domain:www\.foo\.com)$"
Local $sString = "For example, the below entries should pass" & @CRLF & _
"" & @CRLF & _
"https://www.foo.com/" & @CRLF & _
"https://www.foo.com/bar/" & @CRLF & _
"sc-domain:www.foo.com" & @CRLF & _
"" & @CRLF & _
"However the below entries should fail" & @CRLF & _
"" & @CRLF & _
"htps://www.foo.com/" & @CRLF & _
"https:/www.foo.com/bar/" & @CRLF & _
"sc-domain:www.foo.com/" & @CRLF & _
"sc-domain:www.foo.com/bar" & @CRLF & _
"scdomain:www.foo.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")