re = /^(?:https?:\/\/(?:\w+\.)+\w+(?:\/\S*)*|sc-domain:(?:\w+\.)+\w+)$/m
str = 'For example, the below entries should pass
https://www.foo.com/
https://www.foo.com/bar/
sc-domain:www.foo.com
sc-domain:abc.com
sc-domain:www.abc.com
https://www.abc.com/
https://abc.com/
However the below entries should fail
htps://www.foo.com/
https:/www.foo.com/bar/
sc-domain:www.foo.com/
sc-domain:www.foo.com/bar
scdomain:www.foo.com
sc-domain:abc.com/
sc-domain:abc.com/abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end