using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div.*?>((?:(?!<\/?div)[\s\S]|(?R))*)<\/div>";
string input = @"<div class=""my-class additional-class""><div class=""my-class2"">
<div class=""my-class""></div>
</div>
</div>
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}