import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div.*?>((?:(?!<\\/?div)[\\s\\S]|(?R))*)<\\/div>";
final String string = "<div class=\"my-class additional-class\"><div class=\"my-class2\">\n"
+ "<div class=\"my-class\"></div>\n"
+ "</div>\n\n"
+ "</div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}