const regex = /^(.*?@focus)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?@focus)$', 'gm')
const str = `line 1
line 2 and some text end with @focus
line3
line4
line5 end with @focus
line6
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}