$re = '/^(.*?@focus)$/m';
$str = 'line 1
line 2 and some text end with @focus
line3
line4
line5 end with @focus
line6
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);