using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\<\?[^php|\=|xml])";
string input = @"<? voiciun code
<?php coucou
<?
echo
<?=coucou
<?sssssss
<?xml version=""1.0"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}