$re = '/(\<\?[^php|\=|xml])/m';
$str = '<? voiciun code
<?php coucou
<?
echo
<?=coucou
<?sssssss
<?xml version="1.0">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);