import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\").+(?=\")";
final String string = "href=\"https://imss91-ctp.trendmicro.com:443/wis/clicktime/v1/query?url=https%3A%2F%2Fcenturylink.na1.adobesign.com%2Fpublic%2Fesign%3Ftsid%3DCBFCIBAA3AAABLblqZhBnH-aa7sqykOcK27PtbXdtJ21a5jorYZXFoFlwN1HMlRMfrsjgSzpmLlJuRxnhPUR_9TCx5mtSqVMq3GOUc4Aw%26&umid=99FFF6C9-D44F-8E05-8958-2AB9CDA85C9D&auth=19120be9529b25014b618505cb01789c5433dae7-e5e1810cfabbcbf81e7d2124136d2ae10570948f\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}