import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*00(?!1)).*";
final String string = "0- 10- 01- 0010- 1111- 11001001\n"
+ "00- 000- 100\n"
+ "001- 000- 100\n"
+ "00- 000- 1001\n"
+ "foo bar baz\n"
+ "00\n"
+ "001\n"
+ "012345\n"
+ "0012345\n"
+ "00012345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}