$re = '/^(?!.*00(?!1)).*/m';
$str = '0- 10- 01- 0010- 1111- 11001001
00- 000- 100
001- 000- 100
00- 000- 1001
foo bar baz
00
001
012345
0012345
00012345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);