using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"female.*?robot";
        string input = @"animatronic canine female five_nights_at_freddy's five_nights_at_freddy's_2 fox glowing glowing_eyes machine mammal mangle_(fnaf) o-w-l-y_(artist) robot video_games";
        
        foreach (Match m in Regex.Matches(input, pattern))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}