const regex = /female.*?robot/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('female.*?robot', 'g')
const str = `animatronic canine female five_nights_at_freddy's five_nights_at_freddy's_2 fox glowing glowing_eyes machine mammal mangle_(fnaf) o-w-l-y_(artist) robot video_games`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}