const regex = /^(?=.*(?:^|[^\wçığöşüÇİĞÖŞÜ])(?:[iİ]ç|Anadolu)(?![\wçığöşüÇİĞÖŞÜ])).*/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*(?:^|[^\\wçığöşüÇİĞÖŞÜ])(?:[iİ]ç|Anadolu)(?![\\wçığöşüÇİĞÖŞÜ])).*', 'i')
const str = `The text is İç Anadolu here.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}