re = /^(?=.*(?:^|[^\wçığöşüÇİĞÖŞÜ])(?:[iİ]ç|Anadolu)(?![\wçığöşüÇİĞÖŞÜ])).*/i
str = 'The text is İç Anadolu here.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end