package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?'type'A|B|C)-(?'length_or_diameter'\d+)(?:x(?'length'\d+))?`)
var str = `A-5
B-6x3
C-79
A-99x1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}