// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?'type'A|B|C)-(?'length_or_diameter'\d+)(?:x(?'length'\d+))?").unwrap();
let string = "A-5
B-6x3
C-79
A-99x1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}