$re = '/(?:(?:MBVCB|IBVCB)\.(?:[A-Za-z0-9]{1,})\.(?:[A-Za-z0-9].{1,}| )?|(?:[A-Za-z0-9]{1,})\.(?:[A-Za-z0-9]{1,})\.(?:[A-Za-z0-9].{1,})\.(?:[A-Za-z0-9].{1,}| )?|(?:SHGD)\:(?:[A-Za-z0-9].{5,})\.REMARK\:(?:[a-zA-z0-9].{1,};|#)?|(?:##SAL(?:[a-zA-Z0-9]{5,})##BAO#CO#BO#SUNG#GD#TRACE#(?:\d+)#NGAY#(?:\d+)#NOI#DUNG#GD#GOC:(?:[a-zA-Z0-9].{1,}#|#)?))(TIK)([A-Za-z0-9]{5,})(#|-|\.|;|,|\)|)/';
$str = 'SHGD:10002370.DD:240301.BO:BUI#NGOC#LE.REMARK:#TIK127465376';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);