# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:MBVCB|IBVCB)\.(?:[A-Za-z0-9]{1,})\.(?:[A-Za-z0-9].{1,}| )?|(?:[A-Za-z0-9]{1,})\.(?:[A-Za-z0-9]{1,})\.(?:[A-Za-z0-9].{1,})\.(?:[A-Za-z0-9].{1,}| )?|(?:SHGD)\:(?:[A-Za-z0-9].{5,})\.REMARK\:(?:[a-zA-z0-9].{1,};|#)?|(?:##SAL(?:[a-zA-Z0-9]{5,})##BAO#CO#BO#SUNG#GD#TRACE#(?:\d+)#NGAY#(?:\d+)#NOI#DUNG#GD#GOC:(?:[a-zA-Z0-9].{1,}#|#)?))(TIK)([A-Za-z0-9]{5,})(#|-|\.|;|,|\)|)"
test_str = "SHGD:10002370.DD:240301.BO:BUI#NGOC#LE.REMARK:#TIK127465376"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.