using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^([0-9]{1,2}\.[0-9]{1,2}\.[0-9]{4}\s*)(05:00)(?=.*\s+^\1\2)";
string substitution = @"${1}04:00";
string input = @"31.03.2024 01:00 1.002
31.03.2024 03:00 2.003
31.03.2024 05:00 3.007
31.03.2024 05:00 4.985
31.03.2024 06:00 2.987";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}