use strict;
my $str = '31.03.2024 01:00 1.002
31.03.2024 03:00 2.003
31.03.2024 05:00 3.007
31.03.2024 05:00 4.985
31.03.2024 06:00 2.987';
my $regex = qr/(?m)^([0-9]{1,2}\.[0-9]{1,2}\.[0-9]{4}\s*)(05:00)(?=.*\s+^\1\2)/mp;
my $subst = '${1}04:00';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";