#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?:(?=(-*\d-*){7}(\s|\Z))[\d-]+|(?=(-*\d-*){11}(\s|\Z))[\d-]+|(?=(-*\d-*){12}(\s|\Z))[\d-]+|(?=(-*\d-*){13}(\s|\Z))[\d-]+)"
Local $sString = "In the US 555-0198 and 1-206-5705-0100 are examples fictitious numbers." & @CRLF & _
" In the UK, 044-113-496-1834 is a fictitious number." & @CRLF & _
" In Ireland, the number 353-020-917-1234 is fictitious." & @CRLF & _
" And in Australia, 061-970-654-321 is a fictitious number." & @CRLF & _
" 311 is a joke."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")