import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?:(?=(-*\\d-*){7}(\\s|\\Z))[\\d-]+|(?=(-*\\d-*){11}(\\s|\\Z))[\\d-]+|(?=(-*\\d-*){12}(\\s|\\Z))[\\d-]+|(?=(-*\\d-*){13}(\\s|\\Z))[\\d-]+)";
final String string = "In the US 555-0198 and 1-206-5705-0100 are examples fictitious numbers.\n"
+ " In the UK, 044-113-496-1834 is a fictitious number.\n"
+ " In Ireland, the number 353-020-917-1234 is fictitious.\n"
+ " And in Australia, 061-970-654-321 is a fictitious number.\n"
+ " 311 is a joke.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}