using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([""\'`])((\s|((\\)*)\\.|.)*?)\1";
string input = @"<!DOCTYPE html>
<html>
<head>
<meta charset=""UTF-8"">
<title>Catch quotes</title>
</head>
<body>
<Page data-info='Nobody\'s fool' />
<CodeCopier text=`
<h2>It is a</h2>
<h3>functional component</h3>
`>
<h1>Hello World!</h1>
</CodeCopier>
</body>
</html>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}