import re
regex = re.compile(r"([\"\'`])((\s|((\\)*)\\.|.)*?)\1")
test_str = ("<!DOCTYPE html>\n"
" <html>\n"
" <head>\n"
" <meta charset=\"UTF-8\">\n"
" <title>Catch quotes</title>\n"
" </head>\n"
" <body>\n"
" <Page data-info='Nobody\\'s fool' />\n"
" <CodeCopier text=`\n"
" <h2>It is a</h2>\n"
" <h3>functional component</h3>\n"
" `>\n"
" <h1>Hello World!</h1>\n"
" </CodeCopier>\n"
" </body>\n"
" </html>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")