#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(AllowUsers.*)?(\bbob\b)|(.*)"
Local $sString = "AllowUsers richard" & @CRLF & _
"AllowUsers richard jeremy" & @CRLF & _
"AllowUsers james richard jeremy" & @CRLF & _
"AllowUsers jeremy" & @CRLF & _
"AllowUsers bob" & @CRLF & _
"AllowUsers bob billybob" & @CRLF & _
"AllowUsers billybob bob" & @CRLF & _
"AllowUsers billybob steve bob eric bobby" & @CRLF & _
"AllowUsers billybob bobby steve bob eric" & @CRLF & _
"AllowUsers richard bob" & @CRLF & _
"AllowUsers richard bob jeremy" & @CRLF & _
"AllowUsers bob james richard jeremy" & @CRLF & _
"AllowUsers bob jeremy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")