package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(AllowUsers.*)?(\bbob\b)|(.*)`)
var str = `AllowUsers richard
AllowUsers richard jeremy
AllowUsers james richard jeremy
AllowUsers jeremy
AllowUsers bob
AllowUsers bob billybob
AllowUsers billybob bob
AllowUsers billybob steve bob eric bobby
AllowUsers billybob bobby steve bob eric
AllowUsers richard bob
AllowUsers richard bob jeremy
AllowUsers bob james richard jeremy
AllowUsers bob jeremy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}