use strict;
my $str = '12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £6,995
12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £12,995
12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £126,995
';
my $regex = qr/(?>(£[^£]+$))/p;
my $subst = '\\t$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";