import Foundation
let pattern = #"(?>(£[^£]+$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £6,995
12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £12,995
12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £126,995
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\t$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)