using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?:0b[10]+|[0-9]+|'.+?'|"".+?"")";
string input = @" 12 0b110110 ' ' "" "" ""str this is a test string"" 'str this is a test string'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}