$re = '/ (?:0b[10]+|[0-9]+|\'.+?\'|".+?")/m';
$str = ' 12 0b110110 \' \' " " "str this is a test string" \'str this is a test string\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);