// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"]*"(?::(*SKIP)(*F)|)"#).unwrap();
let string = "{\"nextDeliveryDays\":[\"i dag torsdag 20. april\",\"mandag 24. april\",\"onsdag 26. april\",\"fredag 28. april\",\"onsdag 3. mai\"],\"isStreetAddressReq\":false}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}