#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mJ)^(?<log_time>[0-9-]+ [:0-9,]+)\s*(?:-\s*)?\[?(?<severity>\w+)]?\s*[^\w\s]+\s*(?<message>.*)$"
Local $sString = "2022-07-20 15:21:31,994 - INFO - Moving to Dashboard" & @CRLF & _
"2022-07-20 15:21:40,345 [I]: brc.py:118 - Moving to FLB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")