$re = '/^(?<log_time>[0-9-]+ [:0-9,]+)\s*(?:-\s*)?\[?(?<severity>\w+)]?\s*[^\w\s]+\s*(?<message>.*)$/mJ';
$str = '2022-07-20 15:21:31,994 - INFO - Moving to Dashboard
2022-07-20 15:21:40,345 [I]: brc.py:118 - Moving to FLB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);