const regex = /value\s+(one|two|three)\s+=\s+([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('value\\s+(one|two|three)\\s+=\\s+([0-9]+)', 'gm')
const str = `Statistics indicator:0x222235
number of records = 3
records[0]
value one = 2
value two = 5
blocks = 2
block[0] {
some irrelevant data....
value three = 4 bytes
}
block[1]{
some irrelevant data...
value three = 6 bytes
}
records[1]
value one = 3
value two = 5
blocks = 1
block[0] {
some irrelevant data....
value three = 4 bytes
}
records[2]
value one = 7
value two = 6
blocks = 2
block[0] {
some irrelevant data....
value three = 3 bytes
}
block[1]{
some irrelevant data...
value three = 4 bytes
}
Statistics indicator:0x135256
number of records = 2
records[0]
value one = 4
value two = 8
blocks = 1
block[0] {
some irrelevant data....
value three = 6 bytes
}
records[1]
value one = 3
value two = 5
blocks = 1
block[0] {
some irrelevant data....
value three = 3 bytes
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}