import re
regex = re.compile(r"value\s+(one|two|three)\s+=\s+([0-9]+)", flags=re.MULTILINE)
test_str = ("Statistics indicator:0x222235\n\n"
"number of records = 3\n\n"
"records[0]\n\n"
"value one = 2\n\n"
"value two = 5\n\n"
"blocks = 2\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 4 bytes\n\n"
"}\n\n"
"block[1]{\n\n"
"some irrelevant data...\n\n"
"value three = 6 bytes\n\n"
"}\n\n"
"records[1]\n\n"
"value one = 3\n\n"
"value two = 5\n\n"
"blocks = 1\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 4 bytes\n\n"
"}\n\n"
"records[2]\n\n"
"value one = 7\n\n"
"value two = 6\n\n"
"blocks = 2\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 3 bytes\n\n"
"}\n\n"
"block[1]{\n\n"
"some irrelevant data...\n\n"
"value three = 4 bytes\n\n"
"}\n\n"
"Statistics indicator:0x135256\n\n"
"number of records = 2\n\n"
"records[0]\n\n"
"value one = 4\n\n"
"value two = 8\n\n"
"blocks = 1\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 6 bytes\n\n"
"}\n\n"
"records[1]\n\n"
"value one = 3\n\n"
"value two = 5\n\n"
"blocks = 1\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 3 bytes\n\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")