package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:start)(.*?)(?:end)`)
var str = `
startabcend
startdef
blahstartghiend
blahstartjklendsomething
Best working example.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}