re = /(?:start)(.*?)(?:end)/m
str = '
startabcend
startdef
blahstartghiend
blahstartjklendsomething
Best working example.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end