re = /[^\[\]]*(?=(?:[^\]]*\[[^\[]*\])*[^\[\]]*$)/m
str = '8*2 Gripper ${FIRST_HALF?"Ret":"Ext"} [FA-050]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end