import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\w|\\b\"\\b)+";
final String string = "dsf\"dsf sdfd\"asfd as ssd\"f sa fsd f sdf\"sd fsdf sdh\"tyr ujytjf yugtkuh ykhujhjhj \"hello world\" that is";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}