const regex = /(?:\w|\b"\b)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\w|\\b"\\b)+', 'gm')
const str = `dsf"dsf sdfd"asfd as ssd"f sa fsd f sdf"sd fsdf sdh"tyr ujytjf yugtkuh ykhujhjhj "hello world" that is`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}