re = /(?:(?<!\G)“|\G(?<!^|“))[^”]*?\K(?:\b(Volde(?:-?\s*)mort)\b|”(*SKIP)(*F))/mi
str = 'Voldemort has identified an opportunity to create an eighth horcrux. “How can Voldemort cast a Voldemort spell better than a Ron spell?” We can “run” the Voldemort test for Voldemort. “Simply put, Volde-
mort will be doing Voldemort things better than any non- Voldemort actor could,” Ron chanted. But only Voldemort knows where to find the “Voldemort” key to the Voldemort house.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end