import re
regex = re.compile(r"[0-9,.]+", flags=re.MULTILINE)
test_str = ("the number is 1000 today\n"
"the number is 1000.00 today\n"
"the number is 1000.142 today\n"
"the number is 1000.30 today\n"
"the number is 1000.200 today\n"
"the number is 1,000 today\n"
"the number is 1,000.00 today\n"
"the number is 1,000.142 today\n"
"the number is 1,000.30 today\n"
"the number is 1,000.200 today")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")