re = /[0-9,.]+/m
str = 'the number is 1000 today
the number is 1000.00 today
the number is 1000.142 today
the number is 1000.30 today
the number is 1000.200 today
the number is 1,000 today
the number is 1,000.00 today
the number is 1,000.142 today
the number is 1,000.30 today
the number is 1,000.200 today'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end