#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Hub\.config\.set\('\w*',\s*({[\s\S]*})"
Local $sString = "Hub = {};" & @CRLF & _
"Hub.config = {" & @CRLF & _
" config: {}," & @CRLF & _
" get: function(key) {" & @CRLF & _
" if (key in this.config) {" & @CRLF & _
" return this.config[key];" & @CRLF & _
" } else {" & @CRLF & _
" return null;" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" set: function(key, val) {" & @CRLF & _
" this.config[key] = val;" & @CRLF & _
" }" & @CRLF & _
"};" & @CRLF & _
"" & @CRLF & _
"Hub.config.set('sku', {" & @CRLF & _
" valCartInfo : {" & @CRLF & _
" itemId : '576938415361'," & @CRLF & _
" cartUrl: '//cart.mangolane.com/cart.htm'" & @CRLF & _
" }," & @CRLF & _
" apiRelateMarket : '//tui.mangolane.com/recommend?appid=16&count=4&itemid=576938415361'," & @CRLF & _
" apiAddCart : '//cart.mangolane.com/add_cart_item.htm?item_id=576938415361'," & @CRLF & _
" apiInsurance : ''," & @CRLF & _
" wholeSibUrl : '//detailskip.mangolane.com/service/getData/1/p1/item/detail/sib.htm?itemId=576938415361&sellerId=499095250&modules=dynStock,qrcode,viewer,price,duty,xmpPromotion,delivery,upp,activity,fqg,zjys,amountRestriction,couponActivity,soldQuantity,page,originalPrice,tradeContract'," & @CRLF & _
" areaLimit : ''," & @CRLF & _
" bigGroupUrl : ''," & @CRLF & _
" valPostFee : ''," & @CRLF & _
" coupon : {" & @CRLF & _
" couponApi : '//detailskip.mangolane.com/json/activity.htm?itemId=576938415361&sellerId=499095250'," & @CRLF & _
" couponWidgetDomain: '//assets.mgcdn.com'," & @CRLF & _
" cbUrl : '/cross.htm?type=weibo'" & @CRLF & _
" }," & @CRLF & _
" valItemInfo : {" & @CRLF & _
"" & @CRLF & _
" defSelected: -1," & @CRLF & _
" skuMap : {";20549:103189693;1627207:811754571;":{"price":"528.00","stock":"2","skuId":"4301611864655","oversold":false}," & @CRLF & _
" ";20549:59280855;1627207:412796441;":{"price":"528.00","stock":"2","skuId":"4432149803707","oversold":false}," & @CRLF & _
" ";20549:59280855;1627207:196576508;":{"price":"528.00","stock":"2","skuId":"4018119863100","oversold":false}," & @CRLF & _
" ";20549:72380707;1627207:28341;":{"price":"528.00","stock":"2","skuId":"4166690818570","oversold":false}," & @CRLF & _
" ";20549:418624880;1627207:28341;":{"price":"528.00","stock":"2","skuId":"4166690818566","oversold":false}," & @CRLF & _
" ";20549:418624880;1627207:196576508;":{"price":"528.00","stock":"2","skuId":"4018119863098","oversold":false}," & @CRLF & _
" ";20549:72380707;1627207:3224419;":{"price":"528.00","stock":"2","skuId":"4166690818571","oversold":false}," & @CRLF & _
" ";20549:147478970;1627207:196576508;":{"price":"528.00","stock":"2","skuId":"4018119863094","oversold":false}," & @CRLF & _
" ";20549:72380707;1627207:384366805;":{"price":"528.00","stock":"2","skuId":"4432149803708","oversold":false}," & @CRLF & _
" ";20549:296172561;1627207:811754571;":{"price":"528.00","stock":"2","skuId":"4301611864659","oversold":false}," & @CRLF & _
" ";20549:72380707;1627207:1150336209;":{"price":"528.00","stock":"2","skuId":"4301611864664","oversold":false}," & @CRLF & _
" ";20549:147478970;1627207:93586002;":{"price":"528.00","stock":"2","skuId":"4018119863095","oversold":false}}" & @CRLF & _
" ,propertyMemoMap: {"1627207:811754571":"黑色单里(预售) 年后2.29发货","1627207:93586002":"黑色加绒 现货","1627207:412796441":"黑色(兔毛) 现货","1627207:384366805":"米白色(兔毛) 现货","1627207:3224419":"驼色 现货","1627207:1150336209":"驼色单里(预售) 年后2.29发货","1627207:28341":"黑色 现货","1627207:196576508":"驼色加绒 现货"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"});"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")