// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Hub\.config\.set\('\w*',\s*({[\s\S]*})").unwrap();
let string = "Hub = {};
Hub.config = {
config: {},
get: function(key) {
if (key in this.config) {
return this.config[key];
} else {
return null;
}
},
set: function(key, val) {
this.config[key] = val;
}
};
Hub.config.set('sku', {
valCartInfo : {
itemId : '576938415361',
cartUrl: '//cart.mangolane.com/cart.htm'
},
apiRelateMarket : '//tui.mangolane.com/recommend?appid=16&count=4&itemid=576938415361',
apiAddCart : '//cart.mangolane.com/add_cart_item.htm?item_id=576938415361',
apiInsurance : '',
wholeSibUrl : '//detailskip.mangolane.com/service/getData/1/p1/item/detail/sib.htm?itemId=576938415361&sellerId=499095250&modules=dynStock,qrcode,viewer,price,duty,xmpPromotion,delivery,upp,activity,fqg,zjys,amountRestriction,couponActivity,soldQuantity,page,originalPrice,tradeContract',
areaLimit : '',
bigGroupUrl : '',
valPostFee : '',
coupon : {
couponApi : '//detailskip.mangolane.com/json/activity.htm?itemId=576938415361&sellerId=499095250',
couponWidgetDomain: '//assets.mgcdn.com',
cbUrl : '/cross.htm?type=weibo'
},
valItemInfo : {
defSelected: -1,
skuMap : {\";20549:103189693;1627207:811754571;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4301611864655\",\"oversold\":false},
\";20549:59280855;1627207:412796441;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4432149803707\",\"oversold\":false},
\";20549:59280855;1627207:196576508;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4018119863100\",\"oversold\":false},
\";20549:72380707;1627207:28341;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4166690818570\",\"oversold\":false},
\";20549:418624880;1627207:28341;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4166690818566\",\"oversold\":false},
\";20549:418624880;1627207:196576508;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4018119863098\",\"oversold\":false},
\";20549:72380707;1627207:3224419;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4166690818571\",\"oversold\":false},
\";20549:147478970;1627207:196576508;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4018119863094\",\"oversold\":false},
\";20549:72380707;1627207:384366805;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4432149803708\",\"oversold\":false},
\";20549:296172561;1627207:811754571;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4301611864659\",\"oversold\":false},
\";20549:72380707;1627207:1150336209;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4301611864664\",\"oversold\":false},
\";20549:147478970;1627207:93586002;\":{\"price\":\"528.00\",\"stock\":\"2\",\"skuId\":\"4018119863095\",\"oversold\":false}}
,propertyMemoMap: {\"1627207:811754571\":\"黑色单里(预售) 年后2.29发货\",\"1627207:93586002\":\"黑色加绒 现货\",\"1627207:412796441\":\"黑色(兔毛) 现货\",\"1627207:384366805\":\"米白色(兔毛) 现货\",\"1627207:3224419\":\"驼色 现货\",\"1627207:1150336209\":\"驼色单里(预售) 年后2.29发货\",\"1627207:28341\":\"黑色 现货\",\"1627207:196576508\":\"驼色加绒 现货\"}
}
});";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}