package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w\.-]*[a-zA-Z0-9_]@[\w\.-]*[a-zA-Z0-9]\.[a-zA-Z][a-zA-Z\.]*[a-zA-Z]`)
var str = `gabrielpg@unah.as`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}