#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\d+:){2}\d+,\d+ --> (?:\d+:){2}\d+,\d+[\r\n]+([^\n]+)"
Local $sString = "1" & @CRLF & _
"00:00:01,860 --> 00:00:31,210" & @CRLF & _
"Affil of fifth at fat at all the social ball and said, with all this little in the" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:00:31,210 --> 00:01:03,060" & @CRLF & _
"mid limited and will cost a lot, for want of a lot of it is I never do this or below are the innocent of fat in the annual own none will bit less often were a little the earth the oven for the area of some of them some of the atom in the long will recall the law, will cost you the ball a little less of Odessa and coal rule the Vikings in at a loss" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:01:03,980 --> 00:01:33,150" & @CRLF & _
"of our lady of one of the will of the wall routing visiting little sign of the limited use of a lot of wind up with a loss of 14 and uncivil will find a site to lop off call them into solid, a London, can we stop go to work as a gay sailor kissing a lot of that scene of the law that on them in this case" & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"00:01:33,950 --> 00:02:03,190" & @CRLF & _
"will almost a kind wilkinson's, and that a settlement, or the fog collared of the unknown, some would call and all of this was a little, some of us up a lot of letters, union would quit them or not will be or will lend money to zoning and will open the door to that of the novel opens in" & @CRLF & _
"" & @CRLF & _
"5" & @CRLF & _
"00:02:04,240 --> 00:02:24,180" & @CRLF & _
"it and solidity can cut later with boats can die to only see not open only to six and 0:50 and world go ba"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")