use strict;
my $str = '1
00:00:01,860 --> 00:00:31,210
Affil of fifth at fat at all the social ball and said, with all this little in the
2
00:00:31,210 --> 00:01:03,060
mid limited and will cost a lot, for want of a lot of it is I never do this or below are the innocent of fat in the annual own none will bit less often were a little the earth the oven for the area of some of them some of the atom in the long will recall the law, will cost you the ball a little less of Odessa and coal rule the Vikings in at a loss
3
00:01:03,980 --> 00:01:33,150
of our lady of one of the will of the wall routing visiting little sign of the limited use of a lot of wind up with a loss of 14 and uncivil will find a site to lop off call them into solid, a London, can we stop go to work as a gay sailor kissing a lot of that scene of the law that on them in this case
4
00:01:33,950 --> 00:02:03,190
will almost a kind wilkinson\'s, and that a settlement, or the fog collared of the unknown, some would call and all of this was a little, some of us up a lot of letters, union would quit them or not will be or will lend money to zoning and will open the door to that of the novel opens in
5
00:02:04,240 --> 00:02:24,180
it and solidity can cut later with boats can die to only see not open only to six and 0:50 and world go ba';
my $regex = qr/(?:\d+:){2}\d+,\d+ --> (?:\d+:){2}\d+,\d+[\r\n]+([^\n]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}